radmon.org disk failure

More
1 year 5 months ago #5663 by mw0uzo
radmon.org suffered a serious disk failure last Sunday night.

Some further data was restored today, but the web admin interface I used thought it best to remove the previous forum database before placing in the data. I wanted it to merge with what was there already, but it had other ideas   So the last few threads about fixing broken stations are gone.
Please feel free to repost if the issues are not fixed.

Anyone who has discovered their station missing, please re-register. (Apologies to those re-registering for the second time, whoops) 

If you have problems getting running again, let me know on the forum and I'll help to get it working


 
The following user(s) said Thank You: FSM19

Please Log in or Create an account to join the conversation.

More
1 year 5 months ago #5664 by mw0uzo
Replied by mw0uzo on topic radmon.org disk failure
The Seagate ST2000DX001 SSHD that the data resides on is known for failure of it's electronics board. I purchased the drives new in 2014, and one has failed fairly late on compared to others. Not too long ago replacement drive electronics were available for low cost, but those supplies are now exhausted and only a few expensive ones remain. I don't fancy spending £60-70 of radmon.org funds for a PCB, it would be better spent on a new HD or SSD.

With a bit of luck tomorrow I'll be able to fix the map tiles. I have everything in place but they're not working yet due to a permissions problem. I remember having trouble getting them working before, but not the solution. I'll get it worked out.
The following user(s) said Thank You: FSM19

Please Log in or Create an account to join the conversation.

More
1 year 5 months ago #5665 by mw0uzo
Replied by mw0uzo on topic radmon.org disk failure
Frustration post:

Goddammit!! Tiles still not working. Set permissions up ok I think, but get an exception in tileserver when it tries to pull out some tiles. Now messing around with php modules...

Please Log in or Create an account to join the conversation.

More
1 year 5 months ago #5666 by mw0uzo
Replied by mw0uzo on topic radmon.org disk failure
Additional disks/flash arrived to improve. Tiles and database will be store on individual USB3.0 sticks, with backups writing to companion drives. radmon.org is a bit slow at the moment due to everything running on the RPi flash card, this should speed things up quite a lot. With a bit of luck I can get this sorted out on Saturday.

Please Log in or Create an account to join the conversation.

More
1 year 5 months ago #5667 by mw0uzo
Replied by mw0uzo on topic radmon.org disk failure
Step by step: radmon.org database now running on new drive. IO performance much better.

Please Log in or Create an account to join the conversation.

More
1 year 5 months ago - 1 year 5 months ago #5668 by mw0uzo
Replied by mw0uzo on topic radmon.org disk failure
Made a bit of progress fixing the tile server. The tiles file was corrupt! There was no way it was going to read. Downloading fresh, the vector tiles are multi GB size dataset. Website will seem slow while these download.
Last edit: 1 year 5 months ago by mw0uzo.
The following user(s) said Thank You: Bert490

Please Log in or Create an account to join the conversation.

Time to create page: 0.161 seconds
Powered by Kunena Forum
Solar powered Raspberry Pi 4 server stats: CPU 54% Memory 17% Swap 17% CPU temp=72.5'C Uptime 65 Days