MightyOhm GC support?

More
4 years 7 months ago #2940 by ThibmoRozier
Replied by ThibmoRozier on topic MightyOhm GC support?
Looks nice. :D
Sorry about the delay, though.
Kinda forgot. :P

Please Log in or Create an account to join the conversation.

More
4 years 7 months ago - 4 years 7 months ago #2953 by fusebit
Replied by fusebit on topic MightyOhm GC support?
Bug :unsure:
So there seems to be something wrong and before I spend hours to find it, I'll ask here.
Sporadically I do get the message shown on the "screenshot". Maybe every 12 hours or so, I had this very often in the beginning when the GC was sending data every second, then I changed it to every 5 seconds and it semmed to work.

What is the cause for this? Might it be enough to change the GC firmware to every 6 seconds or do I have to change something with the protocol?

PyRadmon is set to mygeiger protocol, the mightyohm ist just sending the CPM value and a CR/LF.





I'll change the timing again, but I would like the system to run stable for months in a row, hence a sporadic error stopping the logging is :sick:

Edit: I just have to restart PyRadmon to make it work again for some hours...
Attachments:
Last edit: 4 years 7 months ago by fusebit.

Please Log in or Create an account to join the conversation.

More
4 years 7 months ago #2954 by ThibmoRozier
Replied by ThibmoRozier on topic MightyOhm GC support?
MyGeiger sends data every 30 seconds, this time shortens when the CPM reaches a certain level, then it jumps to 10 seconds IIRC.
I also see a double CR?

Please Log in or Create an account to join the conversation.

More
4 years 7 months ago #2955 by fusebit
Replied by fusebit on topic MightyOhm GC support?
You're right there is a double CR :oops:

I've checked the code again and found two bugs I introduced last night during the modification.
Now it's sending (really) every 5 seconds and with a single CR/LF :whistle:

Let's wait...

I've mounted the USB interface with stand-off, too. Looks better now.

Please Log in or Create an account to join the conversation.

Time to create page: 2.448 seconds
Powered by Kunena Forum
Solar powered Raspberry Pi 4 server stats: CPU 70% Memory 17% Swap 13% CPU temp=62.3'C Uptime 47 Days